Forum Discussion

Unknown_user's avatar
Unknown_user
New Contributor
2 months ago

Coxwifi Hotspot - couldn't get Ip address

I often connect to Cox WiFi hotspots to save on my wireless data usage. Recently at one particular location I visit frequently, I can no longer connect to the internet. This just started on 6/14 and instantly happened to all my devices at once... I've tried an android phone, 2 different laptops, and a Kindle Fire. 

When I connect with my Android phone, it says "couldn't get ip address." On my laptop running Windows 11, it says it couldn't connect to thr DHCP server. When I click into the menus to get more help on the issue, both tell me one of the primary things to try is resetting the router... Which I obviously cannot do because I don't have access to it. 

Tonight, for a short term, I thought the issue might be resolved when on my laptop after logging in, it told me to open the browser and I finally got a splash screen. I was able to login and connect and had internet for about 3-5 minutes... And then it dropped again and I'm back to the same place. 

I've tried contacting Cox help through chat multiple times to resolve the issue and they seem uninterested in trying to solve the problem. They tend to focus on the fact that my internet at my house is working fine, which of course does me no good when I'm not there. I've even had them ask if I want them to initiate a reset for my home router... Or try to sell me more expensive service. Even when they understand I'm talking about a hotspot, they claim there's nothing they can do. Not a single one has even asked for the location where I'm trying to connect to see if there's anything to be done or to see if multiple people might be having the same issue. 

Is there anything to be done? I don't understand why Cox goes to the effort of creating thousands of hotspots all over town supposedly as a service for their customers, but then does not care if they function properly? 

No RepliesBe the first to reply