This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Emails From cox help@cox com not being received

I have sent 5 emails regarding my Call History not working to the address in the subject line of this post (that included the required periods after cox on both sides of the @).  Moderators on this Forum have told me they were received and answered.  I have not received any of the answers.  I did receive one phone call after requesting it in my 4th email.  I have asked that the contents of the Cox responses be posted to the forum, and faxed to me, and mailed to me, and read to me over the phone so I can see what they say.  I check my Spam folder frequently, and search each one for the letters "Cox" in the address or subject line.  I also do this for any emails in my Inbox that I mark as spam.  I do not have any spam filters set up but I also check my Trash folder to see if any Cox emails have been sent directly there.  I have not blocked any domains.  I have not changed whatever the default sensitivity is for spam or security or whatever.  All other emails from Cox are being received, such as notices that my bill is ready to view online and reminders that my bill is due to be paid in 7 days.  Emails to me from all my other email contacts are being received.  Anyone else having this problem? 

Parents
No Data
Reply
  • Not much help, but I just tested my Call History and it's working.  Do you know of any neighbors also subscribing to Cox?  If so, perhaps the neighbor could try to duplicate your discrepancy within your same enclave.  If not, at the least my comment could test your notification feature from the cox.com domain.

    Just curious...why are you removing the periods from the Help Desk address?

Children