Call blocking of Spam

I have unsuccessfully tried to activate NoMoRoBo and need support. These are the steps performed:

  1. Cox->Settings
  2. NoMoRoBo->ON
    1. Established an account at NoMoRoBo as directed.
    2. Unable to Activate in Settings
  3. Simultaneous Ring->On
  4. Unable to Save. The Save button is grayed out.

How do I save the setting?

On a related issue, I have seen comments on the NoMORoBo interactions, and its failure to block spam. There are the issues:

  1. The Text message seen shows a legitimate address from a legitimate person/enterprise. To remove this phone one must do "Selective Call Blocking", I have seen it initiated as both *60 and *67. Please clarify.
  2. The Text message does not have a phone number. See selective blocking above.
  3. The Text message shows a phone number which Cox recognizes as incorrect. There should be an option to block all such calls. And to this  I not that in order for a call to proceed, Cox must know the actual phone number used. Knowing this number allows communication. Not knowing this number does not allow Cox to initiate of continue the call. Therefore, Cox knows this number and should be able to take appropriate action. And, to this I add, that this is irrespective of whether the actual number is VoIP or conventional. I would like this blocking service!
Parents
No Data
Reply
  • I just gave up on Nomorobo and bought a phone with built in call blocking.  Just set it to screen all calls, entered the contacts that called me the most so they’ll get through right away, and figured the rest of the real callers will announce their name when prompted.  Best investment ever.

Children
No Data