This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Nomorobo Still Not Working

I have had Nomorobo installed since September.  It is still not working.  I have spent hours on the phone with Cox.  After two months they discovered I didn’t have the upgraded service that is required.  They installed it.  It’s still not working.  They won’t do anything more.  They say I need to talk with Nomorobo.  Nomorobo say they have contacted Cox about it. In the meantime, I am getting Robo calls but I refuse to spend one more minute on the phone with Cox.  It is exhausting and discouraging. 

  • There isn't much to setup Nomo...enable SimRing on Cox, enable Cox number on Nomo, enable Nomo number on Cox and then test it.  If you spent hours on the phone, what could have possibly been overlooked?

    I don't understand your "upgraded service" portion.  Is that an eMTA?  If you didn't have an eMTA, SimRing wouldn't have been available in your Cox account.  If SimRing wasn't available, what did you have installed since September?

    I'm not a big fan of Nomo because it has flaws and too many variables to troubleshoot.  It is "exhausting and discouraging" so buy a call-blocker.

Reply Children