This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Gigablast Isn't

When first I subscribed to Gigablast, my download speeds from the modem ranged around 750-850mbps.  Over the last year, I've noticed it has slowed.  Over the past 90 days or so, its dropped to 350 to 550.

I have contacted tech support four times to learn the problem.  I eventually get cut-off on both chat and speaking over the phone...and nothing gets resolved.  I specifically asked if I'm being 'throttled' but they tell me they don't do that.

There have been no equipment changes and, other than an occasional firmware update for the mesh router, nothing else has been altered here.  Is there a secret handshake, a tip jar or bribe account anybody may know about to get Tech Support to actually help?  

Parents
No Data
Reply
  • Cox is probably over subscribing their available bandwidth in your area.  Cable is a shared network so whatever bandwidth is available is for everyone in your local loop.  If there are more users using more data then your available bandwidth will suffer.  Remember, speeds are always quoted as "up to" a certain speed... never guaranteed.

    Considering my own experience with Cox today and recently I doubt they care about your issue and definitely won't do anything about it... Hell I'm getting < 100Mbps with random disconnects and was told I don't qualify for a tech to come out and investigate... 

    Good luck my friend!

Children