Unusably Slow Ethernet Speed from Panoramic Gateway with Gigablast

Hello,

I just finished installing Gigblast wifi today, and my wireless internet works fine.

However, when trying to connect the included ethernet cable to my laptop, my laptop says it connects successfully with internet access, but it is so slow that I can not load any pages. I have tried many possible fixes, such as flushing my DNS cache, re-installing my ethernet driver on my computer, restarting the gateway, and disabling my firewall, but nothing has worked so far. Windows network status says that I am connected to the internet.

For a full list of things I've tried (probably not exhaustive either)...

  • Restarting computer
  • Restarting/rebooting gateway
  • Setting TCP/IPv4 properties to automatically obtain IP/DNS server
  • ipconfig /flushdns
  • ipconfig /release
  • ipconfig /renew
  • netsh winsock reset
  • Disable Windows firewall
  • Disable firewall in Cox gateway settings
  • LAN Ethernet link status is active in Cox gateway settings
  • Try different ethernet cables
  • Try both ethernet ports
  • Disabling/re-enabling ethernet network adapter
  • Check/uncheck TCP/IPv6 in ethernet properties
  • Disconnect from wireless network
  • Ran TCP Optimizer
  • Checked hosts file (nothing in there)
  • Get-NetAdapter in PowerShell shows link speed of 1 Gbps
  • Disable/enable "Automatically detect settings" in Windows proxy settings
  • Windows network reset
  • Clear cache in web browser
  • Tried multiple browsers with all extensions disabled

Any other suggestions would be appreciated. Thank you.