Forum Discussion

Maximus's avatar
New Contributor

Motorola MB8600 modem with Asus AC2900 wifi router. No internet on the router.

Anyone had experience pairing Motorola MB8600 modem with Asus AC2900 wifi router? When I am connected directly through the modem, everything is fine. The wifi router though can't get internet connection from the modem, saying "your ISP's DHCP does not function properly". Any ideas? The router setup was done through the wizard: Automatic IP, no password.

3 Replies

  • Maximus's avatar
    New Contributor

    The solution to the problem was to clone the MAC address. It was just a two-click fix. Problem solved.

    • Andrew_Wees's avatar
      Contributor III

      actually there is/should another way unplug everything then plug modem in wait for it to finish then turn router on

  • KevinM2's avatar
    Former Moderator
    Hi Maximus, I ran some tests on the modem which caused it to reboot temporarily, and I did not find any issues on our end. As you've indicated that you are able to bypass the router and obtain a hard-wired connection directly through the modem, we recommend contacting the manufacturer of the wireless router for additional support. -Kevin M. Cox Support Forum Moderator