Forum Discussion

forumokie's avatar
New Contributor

Windows Update fails while connected to Cox Internet Service

Windows Update fails on both my desktop and my laptop when I am connected to Cox High Speed Internet Service.  However, when I activate my phone as a mobile hot spot and connect that way (it's not Cox), Windows Update instantly works correctly!

I have googled, binged, and altavistaed, searching for solutions.  All suggested solutions are over a year old.  I have tried using Google DNS servers ( e, tried a clean boot (deleting contents of c:\windows\SoftwareDistribution), disabled Windows Defender, run Windows Update Troubleshooter, tried modifying the Hosts file, modified the registry, and a few other tweaks I ran across--but all to no avail.  Windows update continues to fail when connected to Cox internet.

The error I got at first was "There were some problems installing updates, but we'll try again later. If you keep seeing this and want to search the web or contact support for information, this may help: (0x8024402f)."  After trying the clean boot fix-wanna-be above, instead of an error message, I get "Updates are available.  Downloading updates 0%."  And there it freezes with no download actually occurring.

I am running Windows 10 Home Version 1607 (not the newer Creators Update, which is Version 1703).  When the trouble first started, I was running OS Build 14393.726.  I was able to download and manually install KB4019472 (OS Build 14393.1198) successfully on both of my machines, but the automatic update problem still persists.  Windows Update refuses to work (search for updates, download, install) unless I disconnect from Cox Internet and reconnect using my phone's mobile hot spot.

I have a Cisco router here at home connected to my Motorola SurfBoard cable modem (purchased from Cox a few years ago) and the problem persists whether I connect via wifi or by wire.

The problem seems to be connectivity related.  Is Cox playing with DNS records or caching Microsoft's update files to avoid downloading the same file millions of times over?  And maybe something is corrupted along the way?  Or could it be my router or the cable modem? The fact that updates work perfectly on both my desktop and my laptop when connected to my phone's mobile hot spot tells me that the problem is NOT in the software or hardware on my computers.  The problem seems to be somewhere along the path provided by Cox between my computers the microsoft servers (but not including them).

I'm a retired high school computer science teacher, still a learner, not an expert.  Does anybody have a solution that actually works?


1 Reply

Replies have been turned off for this discussion
  • forumokie's avatar
    New Contributor

    I found the solution!  All I had to do was login to my router's interface and, under Security/Firewall, uncheck the option that filters ActiveX.  Windows Update immediately started working properly on both my desktop and my laptop.  It checked for updates, found them, downloaded them, and installed them.  Then said my computer was up to date.  Based on this, your solution likely would have worked also.  But now I know specifically why updates were failing.  It just took me two months to find out why.  I should have known that Microsoft would be using ActiveX.  Duh.  Hopefully this will help someone else along the way.  Thank for your time.  You may mark this problem SOLVED.