Forum Discussion

Robert_R's avatar
New Contributor

What is going on with the e-mail?

I have been having fits getting my email to load since the "upgrade".  I'm having this issue on multiple desktops that have different antivirus/security vendors.  I've tried using different web browsers and being on an incognito page.  I've deleted all of my browser internet settings.  I've tried every trick that I can yet more than half the time when I attempt to access my inbox I get 3 flashing dots in the center and nothing more.

I tried an online session with a Cox agent yesterday who told me that there is some sort of widespread issue with e-mail but wouldn't give me any type of detailed information.

I just spent 10 minutes on the phone with a customer support agent who assured me that I have used rather than or that it would solve the problem (because of course while I was on the phone with him my inbox actually came up).  After closing the browser and returning several minutes later though (to SAME ISSUE!  Also, this agent assured me that this is NOT some type of widespread issue.  Can your customer service people at least get on the same page?

So I will ask for the 3rd time, is there a widespread issue and are there any known fixes.  If there are not, what is the time frame that this will get fixed?  I have never had ANY problems with my cox e-mail before (I have been a customer for over 10 years) so this is EXTREMELY frustrating.  I use my e-mail for some business correspondence as well as personal so this is simply unacceptable.

By the way, my e-mail is being delivered just fine on my android phone but there are some items that I need to address on a desktop rather than my phone.

Can you please help with this?

2 Replies

Replies have been turned off for this discussion
  • grrrr's avatar
    New Contributor

    This is ridiculous!  I have tried for weeks now to access my webmail on various desktops with no success!!!  I repeatedly enter my username and password and am directed to a security screen asking for the last 4 of my social.  I enter the information and receive a notice that an error occurred and to try again later.  Its been weeks later, and still nothing!  I don't see the point in upgrading something if it is not going to work.  

  • grrrr, are you trying to access the webmail while out of the country by chance?

    Cox Support Forums Moderator