Forum Discussion

bes1008okc's avatar
New Contributor

Outlook client still prompting for password continuously

The issue still exists. Technical support says Cox is still having issues supporting the Outlook client. Webmail works fine. I can send/receive from my iPhone just fine. What's the latest estimate for a fix??

4 Replies

Replies have been turned off for this discussion
  • JonathanJ's avatar
    Former Moderator

    We currently don't have an ETR the walk around is to use webmail We apologize and thanks for your patience.

  • Tmax's avatar
    New Contributor

    I've been having the same problem for a week. Send/receive attempts work less than 30% of the time with no change to settings or PW. I've tried 587 with TLS enabled & 465 with SSL - no change. I've had this problem in the past and it seems to eventually go away. Seems like a common recurring issue with Cox email for several years based on forum searches I did trying to find a solution.

    This is happening on my Outlook 2010 client on a Windows 10 PC as well as on a Gmail client on an Android tablet - both using a POP connection. No way that Cox can blame this on the email application. Both were working fine before.

    This significantly reduces productivity as well as being extremely annoying.

  • Eeuclid's avatar
    New Contributor

    Experiencing the same issue.  Spent 1hr between online chat and phone call with tech.  "Tried" some changes to settings, and password, but problem continues.  Occurs to different user id's at different times.  Extremely inconvenient. 

  • bes1008okc's avatar
    New Contributor
    I was able to successfully setup a POP account with Cox’s recommended settings. :-) The trick is when you get the popup window asking for username/password is to remove the “” from the username cell. I tried IMAP first without success including no “” in the username cell. POP worked just fine. I prefer POP because I can have incoming emails go to a designated .pst file.