Forum Discussion

nolagardener's avatar
New Contributor

On Demand Disappeared from Tivo Roamio


The Cox On Demand app recently disappeared from my Tivo Roamio.  Were there any recent updates or changes which may have disabled it?  Any help would be greatly appreciated.  Thanks.

20 Replies

Replies have been turned off for this discussion
  • Andrew_Wees's avatar
    Contributor III

    check in v settings/channels/my video providers make sure cox on demand is checked

  • Sorry, I forgot to mention I checked the video providers settings first; the Cox On Demand app isn't listed anymore.  It's almost like the cable card needs to be reauthorized to access the app.  

    Thanks for your help, though.

  • Yes, all of my channels are coming in.  The light on the tuning adapter is also solid.

  • Andrew_Wees's avatar
    Contributor III

    I'm going to share your post in my thread to see maybe our issues are related someway  all I have been getting are blue spinning circle's since Tivo update the software to 20.6.3

  • Hi Nolagardener,

    I'm not sure how we missed your post. I'm sorry! What TiVo software version does your Roamio have? Software version 20.5.2 (or later) is required. Have your TiVo account settings recently changed? Within the My Account section of your online TiVo account, click Change DVR Preferences. Is there a check mark in front of Video sharing and Enable video downloads? If yes, uncheck the boxes, click Save, and return to DVR preferences to recheck them. If no, check-mark the boxes for Video sharing and Enable video downloads and click Save. Then, force a connection to the TiVo service by going to Settings & Messages > Settings > Network > Connect to the TiVo service now. After this process, has the Cox On Demand launchpoint returned?


  • No, unfortunately those steps didn't make the Cox On Demand launch point reappear.  I called the cable card support line and was informed this is related to a known issue with On Demand for Tivo that is currently being worked-on.  Before I hung up, the rep confirmed my cable card still was still provisioned with the correct codes.

  • Hi Nolagardener,

    We do have an open alert related to Cox On Demand for TiVo devices, so I'm sure the tech you spoke with had this alert in mind. However, I don't believe what you are experiencing is related. My supervisor has a TiVo Roamio, and has not lost his Cox VOD launchpoint.

    Have you gone through all of the steps I mentioned yesterday? Page reference:

  • Good evening,

    I tried the steps listed in the Tivo Support Forum you mentioned and the Cox On Demand launch point did reappear!  However, I have not been able to successfully open the app on my Roamio; whenever I click on the launch point, I receive a V301 - App Currently Unavailable - message.  I tried rebooting the box several times and forcing several successful  connections to the Tivo Service over the past few days, but the message / issue persists.  Is there anything else I can try to get the app to open?  All other applications work fine - Netflix, Youtube, Hulu, etc.

    Thanks again for your help.

  • Mark_K's avatar
    New Contributor III

    I just solved this problem on my bolt.  You're right, rebooting and connecting didn't fix it for me.

    What got rid of the V301 error was to reload the guide.  (Found under help -> reset menu)