Forum Discussion

Dndrhead's avatar
New Contributor

My PC is getting 4mbps download and 0.01 mbps upload while I should be getting what is advertised on Cox Premier.


I am suffering from a very extreme issue which has caused me uncanny amounts of frustration. It took me about ten minutes for Cox's website to even load to the point where I can type out this forum post.

My PC is hard wired into my modem/router combination that I purchased from Best Buy brand new about three days before my service began. I set up my own internet at my apartment, and configured my wireless settings the way I wanted them with name and password, etc. Every other device that I have had hard wired into my modem/router has received upwards of 49 mbps - my computer, however, is only getting, at MOST, 4. On average, however, it's about 2/2.5 mbps, and dips as low as 0.5 mbps. 

I know that this must sound like it's an issue with my computer as opposed to my service from Cox, but I have tried everything I can think of - reinstall drivers of mobo and ethernet port, update Windows (7) fully, check my firewall, check to see if somehow there was a blocker put on in my modem/router's settings...nothing has come up helpful whatsoever. I've had a friend take a look at my computer through TeamViewer as well, and, as he was a former employee of Cox, he recommended that I call, because it seriously looks like it could be on Cox's end.

So I have called about 4 or 5 times, each call ending with some frustration or another, and ultimately not really resolving my issue. I've resorted to having a tech scheduled to come and check things physically, but I want to try every window I have before that happens.

Now, I know for a fact that my computer is more than capable of receiving speeds higher than 4mbps, and I have proof. I have attached a picture from Cox's website's speed tester, while I was hard wired into my dad's internet at his house. My dad, by the way, goes through Century Link.

(I should note that, from start to finish, it took three minutes to insert that picture inline.)

The only information that was changed in that image was the IP address, which was removed for privacy reasons.

Although those may look like low speeds, my dad does not have a very high plan with Century Link - he gets about 40mbps as a high for download speed. That right there is my computer achieving 36.

I find it entirely strange that my computer, on Century Link's internet, can receive the right amount of service, whereas when I am connected to a Cox serviced network, I am receiving about 3% what I should be. How can it be my network card, if I receive higher speeds elsewhere? How can it be my modem/router, when A) I am hard wired and B) other devices that connect to it are receiving much higher speeds (which, mind you, 49 is still less than 150.)? How can it be my computer's settings when, again, it does not interfere with another network?

I'm simply stumped. I've Googled, I've called, I've spoken to techies online. Nothing. No one can figure this out. I really would *love* to have my full service, and continue paying for what I pay for, but how can I do that when I pay for something I'm not even getting?

2 Replies

Replies have been turned off for this discussion
  • Dndrhead's avatar
    New Contributor

    I should also note that, out of the four phone techs I spoke with, only two of them were courteous and helpful. Out of the others, one of them blamed my *hard wire* on my modem/router, and tried to sell me something I do not need for $150. The other said that, while my modem/router look good, my network card is "red". That person did not have the benefit of photographic evidence of the contrary, mind you, but. Still.

  • Hello,

    We can certainly look into this issue for you. Please send us an email with your full address to 


    Allan - Cox Support Forums Moderator.