Forum Discussion

jfangman's avatar
New Contributor

Internet working for one computer from router and not working from modem

This is a very weird problem that we have spent over 2 hours on the phone with multiple cox representatives and over an hour on the phone with multiple geek squad representatives.Please let me know if you have any ideas how to fix this.

Hardware: Brand new netgear modem, old motorola modem that worked in previous house, multiple different cisco routers, plenty of ethernet cords, multiple wall coaxial wall outlets.

Problem: We moved into a new house an are attempting to connect to the internet for the first time. When we set it up, we connected the modem to the coaxial wall outlet, and connected the modem to a router. The wifi worked for one computer(HP running newest windows), however, the wifi did not work for any of our other devices(Macbook Pro with newest software. multiple generations of iphones running different software versions). We then tried running ethernet from both router to computer and modem to computer, and not a single hardwire connection works to any computers including the one that worked originally with the wifi. We then ran it with the old modem from the old house and had the same exact issue with the one windows computer working with wifi running from the router, but not working with hardwire and all other devices not connecting no matter the connection type. We have tried with different routers, modems, ethernet cords, wall outlets, everything we can think of. We have completely unplugged every device from every cord and let sit for 5 minutes and replugged everything one by one but nothing works. On my mac when I try to connect, it tells me that it is creating a self assigned IP address 169.XXX.XX.XXX. I know that this means it is a problem with the DHCP not connecting as it should. On the computer the wifi is working, the IP address is 68.103.XX.XX which does not seem right as I thought that most were set as 192.XXX.XX.XX. The iPhones are attempting to connect to this 169.XXX address as well. We have attempted restarts of hardware, forgetting networks, turning everything off, renewing leases, yet nothing works. I am lost for a solution and cannot think of anything else I can do to fix this. From talking with Cox, they said over the phone that everything from their end of the equation seems to be working correctly, but I cannot think of anything we haven't tried. Please let me know if you can think of anything.

TLDR: One computer works with wifi from router, but not with ethernet from router of modem directly. Mac and iPhones do not work with either wifi or ethernet. Tried different modems, routers, cords, restarts, turning everything off for minutes, nothing fixes.

1 Reply

Replies have been turned off for this discussion
  • ChrisW's avatar
    Former Moderator

    Hello @jfangman,

    Judging by the symptoms you are experiencing, there may be an issue with the router's internal DHCP system and may be acting as a bridged connection. Instead of assigning a normal private IP address (192.X.X.X), one device receives the public IP passed through the router, and all other devices receive a self-assigned IP address. As to why no hardwired connections will work, that may be a few different things. When connected directly to the modem, are you seeing the link light appear on the modem and does the connection show up on your computer's network configuration window? If the Ethernet connection does appear, what does the first octet appear as?