Forum Discussion

Daryles's avatar
New Contributor

Foreign travel access to webmail

Dear Cox, I travel frequently to foreign countries. Your network security obviously detected that I am connecting with a foreign IP address and prompted for my last 4 SSN AND asked me to select "all castle looking pictures" to ensure I was human (or something). This works fine on my laptop computer BUT it did not work at ALL on my android phone. Where pictures are supposed be displayed was a blank frame. What procedure do you have for someone trying to connect to their Cox Webmail account using an android phone while on foreign travel? Thanks in advance.

11 Replies

Replies have been turned off for this discussion
  • My wife and I travel extensively, often going to Europe, Africa, Middle East, etc.  We have done so extensively, and have always been able to use Cox web mail when overseas.  On our last trip, to Germany, Austria, and Saudi Arabia over Christmas and New Years, 2016k - 2017, suddenly found that we could no longer send emails on Web Mail.  Unable to email relatives, friends re: delayed arrivals, etc.Finally called Cox to find out what was going on. Got the usual "never heard of that" and 'that shouldn't b happening." from the techs. After much time on the phone (from Saudi Arabia ultimately was told that we now had to notify Cox prior to leaving the country so their committee could approve out foreign travel.

    Three days ago wife left Phoenix to go to Dhahran, Saudi Arabia too take care of grandkids for daughter and husband. Called in advance to inform Cox, and now was informed that not only had to inform of travel, but had to submit specific IP addresses for approval.  While we could get the specific IP address for their home on Aramco In Saudi, and then wait the stated 24 hours for the committee to approve or disapprove, this process leaves out airport wi-fi servers in an emergency at some god-forsaken middle eastern airport.

    Cox does not notify you if the IP address has been approved or disapproved. Still not working, must have been disapproved?

    Cox puts in these unexpected changes without notifying its customer, even those like us who have been so for 29 years, and pay 230 bucks a month, expecting premium service, and doesn't even tell their techs that they're going to do or what they've done.  Different answer with each call on he problem.

    Will fire Cox as soon as a viable alternative is found.


    An additional layer of security is in place that provides real-time protection against identity theft, data breaches, and fraud. You should be prompted to enter additional verification on new devices when accessing any of the following pages on our website:

    •Internet Tools
    •My Account
    •My Services
    •Phone Tools
    •View/Pay Bill
    •WebMail / Cox Email

    This additional verification automatically allows you to sign in on the device without having to contact our customer care team for additional support. This verification would be required on each device you are trying to obtain access with.

    I have not seen any cases where access was denied for any customer where a ticket was put in due to being unable to complete the additional verification. Typically the request to grant access is completed within 24 hours or less.

  • TechHater's avatar
    New Contributor
    Dear Cox, I have a similar, but not identical, problem as Horace Jones. I am in Mexico, and on my last trip here, I had no problem accessing my webmail - it obviously detected that I had an out-of-country I.P., and thus prompted me for the last 4 of SSN, and then a reCAPTCHA challenge. I appreciate the extra security measures - that's not my issue. The problem came on this second trip down here, when, after I enter the last 4 of SSN, the screen hangs, and after a couple of minutes, I get a msg that says "Your browser does not support the reCAPTCHA widget", or something like that. Baloney - I'm using IE 11. BUT, just to be sure, I followed the instructions, and tried Chrome, Edge, and Firefox - latest versions of each - and the result is the same every time. Can't get to the reCAPTCHA screen no matter what I try. I'm up-to-date on Windows 10. I installed the latest version of Java. I cleaned my Internet Temp files and Cookies. I have tried from different Wi-Fi sites (hotel and work) - NOTHING seems to work. Oh, and your "Live Chat" - how do I reach that w/o signing in ... which I can't do? You guys are going the way of CenturyLink - i.e., useless. Help, please!
  • EricaW's avatar
    Former Moderator

    Hi, TechHater,

    We can help you get the support you need. It will require another method of verification. Please email us at and include this link.

    Erica W.
    Cox Support Forums Moderator

  • Zorkey's avatar
    New Contributor

    Apparently I've also fallen victim to Cox latest lock down.   I'm in the UK this week and just tried to log into my webmail account and am unable to do so.  I'm using a Mac (10.12.6) and I've tried both the Chrome and Safari browser and neither of them displays the captcha that is supposed to come up after entering the last 4 digits of your social security number...  Whats particularly frustrating is you can't even initiate a chat session to try and get help...   I've emailed from another email account for help... I wonder if any will be forthcoming.  Any assistance would be most appreciated.


  • StephanieA's avatar
    Former Moderator

    Our address is and not Please resend the email for us to review.

  • jmnew's avatar
    New Contributor

    We have been having exactly the same problem. In the UK, currently can receive but not send emails via my iphone app, but when I try to log into Cox via a computer (mac) I am prompted for my last 4 SSN, then it locks up and says there is an error and won't display recaptcha. An hour on the phone with tech support and absolutely no help. They then told me they would come back to me in 48 hours, though I have no confidence the result will be different. It seems from these posts that this is a known problem - surprised they have not bothered to share awareness of this issue with the tech support teams, as it seems to be a common problem over the last month for people traveling overseas.

  • JonathanJ's avatar
    Former Moderator

    Please email full address, primary name on the account and user ID.

  • Hazed's avatar
    New Contributor

    Same issue!  In Italy and cannot send email and cannot login to webmail.  Get this same message.  And I cannot email you because I cannot send email while on wifi!  HELP!  I can receive email fine.

    I cannot even login to my cox account.  Huh, guess I don't have to pay my bill!