Forum Discussion

webmail_quality's avatar
New Contributor

Do you plan to ever fix webmail?

Ever since you pushed out your "upgraded" webmail: "" or whatever it is, the performance in general is slower. But the biggest annoyance--and it's a big one--is the way messages are automatically selected.

If I open an email, the check box next to it is clicked, and it remains clicked unless I manually uncheck it. Or, if I selected a message to delete or move to spam or any other action, once that message is moved/deleted, the next message in the list gets selected automatically. This makes it extremely easy to perform an action on a message unintentionally.

To explain more clearly, since your chat 'help" couldn't understand:

Say I have 30 messages showing. If I click number 23 and move it to spam, then without me intending, the next message (24) is automatically selected. But I didn't select it, your inferior mail app did. So if i then select another message, say number 18, and delete it or move it to spam, I move it and accidentally move message 24 also. I am constantly having to undelete or remove items from spam. 

This is new with your 'upgrade' and no other email system I use does this. It's a Cox thing. 

Oh, by the way, removing all of my filters and allowing a lot more spam through is a really nice treat also. Thanks for that.

I really don't want to have to change my email address with all of my friends and family, but I do not intend to continue using your inferior mail service. Please fix it. Please update as to when you'll fix it. I was never a big fan of gmail, but if I have to start using it, I guess I will. 

6 Replies

Replies have been turned off for this discussion
  • Navy_Mom's avatar
    New Contributor

    I couldn't agree more. I am also receiving more SPAM than ever before, Cox's spam blocker is broken! There was a time when I rarely received any spam emails and now I receive at least 1-2 per day, sometimes more!  Please fix it.  I am not happy with the new Webmail either.  I'm also dealing with errors in the middle of composing an email and, of course, it's always when I'm nearly done writing the email. All of the sudden my email gets messed up, I don't even know how to explain it.

    Seems to me that your developers need to go back to the drawing board and rethink your new webmail.  I am not happy at ALL!

    Thanks Cox!

  • while i have my own thread on the apps forum about this mess, i have a possibly useful insight here.

    it's taken some retraining on my part, but if you click on the body of the email, it will uncheck the auto checked box & check only that email.  if you check the next box on the select box, however, now both are checked. then just make sure you uncheck that last box before you go  it's a new habit to develop.

    i also hate the way it "counts" emails in a folder.  i finally figured out it thinks it's reporting the number of "unread" messages, but it's still wrong. i currently have "1" in my spam folder.  but it's empty! and "select all" only selects what you see on the screen or 50.  haven't figured that out yet.

    but the sorst thing about spam is that most of what's going in legit!  like receipt for an online order.

    meantime, i got a phishing scheme email purportedly from cox last week in my inbox. seems like they'd have a few filters they could apply.  for the rest of it they seem to be using our free labor to build with.

  • Dawnuh's avatar
    New Contributor

    I use webmail when traveling and Live when at home.  The spam filter on the webmail is catching emails that are not spam so that those messages never reach Live.  That means I have to sign in a few times a day under both webmail and Live.  My husband has several friends who email him and those messages never appear anywhere.  HELP!

  • ChrisL's avatar
    Former Moderator

    In Webmail, you can go to Settings to change your spam filter preferences. The least restrictive option would be to deliver to inbox tagged as spam which would allow the email client program to also receive them.

  • Dawnuh's avatar
    New Contributor

    Under settings in webmail, there is no place where preferences come up.  I see what's supposed to appear in "email" in the help section, but maybe that doesn't apply to webmail????

  • Hi Dawnuh,

    When you open your Webmail Inbox, click on the Gear icon in the upper right-hand corner to open Settings. Then, on the left-hand side of the page, click on the little triangle next to "Inbox" to access the Preferences menu. Click on "Spam Settings" and choose "No Spam Filtering" to have all email messages delivered to your Inbox. Please let us know if we can assist with other questions!