Forum Discussion

CCFlint's avatar
New Contributor

Cox's Web Page has Numerous Dead Links

I'm using Chrome as my browser and am amazed at all of the "dead" links on the Cox support website. I can click on every single topic under the "How to" section of In Home Wi Fi and none of them go anywhere.  is it just me? I don't get a lot of confidence from an IT support site that can't maintain a web site.

6 Replies

Replies have been turned off for this discussion
  • Hello,

    I am not able to reproduce this issue on our side. Are you getting any error messages? Also, can you duplicate this with a different browser?


    Allan - Cox Support Forums Moderator.

  • Angels1958's avatar
    New Contributor

    I am experiencing the same issue for a couple of weeks as CCFlint. The rollover links for the following questions on the data usage page don't work: I have tried in several browsers (Chrome, Firefox and Safari) and they all don't work. Ever since the page was updated on Dec 5 and Dec 19, I can't read the responses to the below questions.

    Will I be billed if I exceed these plans?

    Will Cox throttle my speeds if I exceed my data plan?

    How quickly will I see my data usage appear on the Data Usage Meter?

    What time period does my data plan cover?

  • CCFlint's avatar
    New Contributor

    I haven't tried another browser but as of tonight, it's doing the same thing.  Chrome Version 55.0.2883.95 (64-bit)

  • Karen_R's avatar
    Former Moderator

    The Cox site is loading the How To sections. Please try again and let us know if there is any problem. Thanks
  • AllenP's avatar
    Valued Contributor

    Karen_R, did you test the page referenced by @Angels1958? It's the Data Plan FAQs page off Internet Tools. The 4 questions at the bottom of the page, just above "Rate this Article", have a dropdown arrow but do nothing! Nothing happens in either Chrome or Firefox when you click on the question or arrow. That's the only specific example given in this thread and it still doesn't work.

  • Angels1958's avatar
    New Contributor

    ^Continues to not work for me, too. No response from Cox to my observation to my points made about a week ago.