Forum Discussion

CraigP's avatar
New Contributor III

Cox website not working with Windows Creator 1703


I have several laptops with Windows 10 Version 1607. The Cox website works fine with those. On one laptop, I have Windows Creator Version 1703. All the websites I go to work fine except the Cox website. It does not load, or partially loads, then hangs up. I have used Chrome, Internet Explorer, and Edge, all with the same results. Just thought you might be interested in this. 

  • The latest update to Windows Creator 1703 I received today (6/28/17) appears to have fixed the issue. Unless Cox just changed their website as well.

8 Replies

Replies have been turned off for this discussion
  • StephanieA's avatar
    Former Moderator
    We will need to see a trace route to help get this resolved. Since the trace will include your IP address, we don't suggest posting it in here unless you are able to mark out only your IP address. If you are not able to mark it out, please email us at with the trace, the account details, and a link to this post to review.

  • AbleTec's avatar
    New Contributor

    I'm having the exact same problem. I've tried 4 different browsers, I've cleared cache & cookies, & I finally rolled back the update just so I could sign in again. But somewhere along the line, & it won't be long, I will be forced to update, so I hope Cox & MS can work together to figure out what the incompatibility is & fix it. BTW, Cox, I was receiving messages per the following when using developer tools w/Firefox to troubleshoot the issue:

    Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user’s experience. For more help

    &, once the connection timed out, I got this:
    Secure Connection Failed
    The connection to the server was reset while the page was loading.
    • The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
    • Please contact the website owners to inform them of this problem.
    Learn more…

    Please work on this ASAP! I cannot imagine Craig & I are the only ones w/this problem.

  • ChrisL's avatar
    Former Moderator

    Are you by chance using any kind of connection privacy features on your connection?

  • CraigP's avatar
    New Contributor III

    Another interesting note, if I open up versus, I can get further into the website before it locks up. At some point when navigating, .net redirects to .com and then the lockups start occurring. I thought it might be Adblock related, but I have Adblock on both Window versions, 1607 and 1703, and again 1607 works fine. In Chrome, I deselected block third party from setting cookies to see if that had an effect, made no difference. There appears to be definitely some compatibility issues between 1703 and the website coding. There was a new update to 1703 last night, I hoped that might address the issue, but the new update also didn't change anything.

  • Thank you for the additional information. I have a laptop at home with the newest Windows 10 (Creator) update and it appears to be working OK with access to the Cox web site. I also have a computer that has the previous version of Windows 10 and it also checks out OK. What are you running for Anti-Virus programs? Do you have more than one installed?
  • CraigP's avatar
    New Contributor III

    I am using Windows Defender for my antivirus on all computers. That is the only antivirus I am using. This morning another one of my laptops updated to 1703, and the same problems occurred on that laptop after that laptop updated. The only way I can now access the cox website is with this computer I am using now, that has not updated to 1703.

    Also, it is not browser related, The problem occurs on Edge, Chrome, and Internet Explorer. I did all the usual checks, clearing cookies, deleting browser histories, disabling extensions, etc, and the problem remains.

    If I had to guess, it would be in 1703 security or safety update portion, that no longer likes the site. I have not tried, and am reluctant to turn off the Windows Defender to see if it is the cause.

  • Hi, on the laptop that just updated to 1703, roll it back with a previous restore point and see if you are able to connect to the internet and access the Cox web site as usual. I re-tested again on my laptop that has not upgraded to 1703 and my main computer which has the latest update and both are able to navigate the web site as usual. By the way I tried Chrome and Microsoft Edge and they worked equally as well. I looked at the Microsoft tech forums and there are issues being reported to Microsoft concerning the update.
  • CraigP's avatar
    New Contributor III

    The latest update to Windows Creator 1703 I received today (6/28/17) appears to have fixed the issue. Unless Cox just changed their website as well.