Forum Discussion

AbleTec's avatar
New Contributor

Cox website not working with Windows Creator 1703--revisited

This topic was discussed previously at:

& although the gentleman involved was fortunate enough to solve this via a later update, such was not the case for me.

Actually, the later update made it worse, such that I was unable to sign in at all. Again, I found it necessary to roll back to a previous version of Windows. I run an Asus 555LAB laptop w/8gb RAM & a TB of hard drive space. I have Cox preferred internet. I have tried this w/various browsers, including Firefox, Chrome, & Edge. I have allowed popups, & permit 1st & 3rd party cookie tracking. I run Windows Defender & Windows Firewall, so nothing unusual there. Errors in the developer tools console include:

Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user’s experience. For more help
Secure Connection Failed
The connection to the server was reset while the page was loading.
• The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
• Please contact the website owners to inform them of this problem.
Learn more…    t"

I hope somehow this can be fixed, as there will undoubtedly come a time when I will be forced to accept this update, & I am not anxious to be locked out of my Cox account. Any help appreciated. Thank you.