Forum Discussion

AZrob's avatar
New Contributor III

Cannot receive emails via IMAP on Mac Mini's Mail (Apple Mail)


The other day I switched from POP to IMAP protocol on my Mac and my iPhone. On my iPhone I can send and receive email just fine, but on the Mac, I can only send. No emails will arrive - I can just sit and wait and nothing comes in.

There is a workaround: if I i disable then re-enable the mail account, any mails that are waiting to come to me will show up. I can also stop and start email itself and the waiting emails will show up. But if I just set up email to query every minute, or if I push the Send/Receive button, nothing arrives.

I called COX and had all my settings checked out. They said it was a problem with Apple because the iPhone works but the Mac does not. However, then I bought another brand new Mac, same exact model (Mac Mini), and the first thing I did was configure Mail for IMAP - same result.

I called Apple and managed to get someone in high-level Mail Support. They immediately recognized the issue: they said that the way Cox has implemented IMAP, there is a problem on their side with the "push" functionality. It doesn't work yet with all platforms. The reason it works with the iPhone and not the Mac has to do with the fact that each is connected to the Cox mail server in a different way. The iPhone way works, the Mac way does not. 

Apple said that Cox has acknowledged the problem and they are working with them, on a high-level developer/engineer level. to resolve the problem. 

If Cox had had IMAP in operation for a year, I would find this not so believable - but I know that it's only been a few weeks, and rollouts always have issues. I believe that Apple is correct when they say this is a COX rollout issue.

What I would like to hear from COX is some announcement recognizing this problem and an ETA for when it will be fixed. Could someone respond to that please?

And please don't tell me this hasn't been reported as an issue, as other Tier 1 reps have told me. It may not be on the radar for the people who work the front lines, but this obviously is an issue that needs to be addressed.  It's only been a few weeks, and since we are only talking about Mac users, it's possible this has not gotten enough attention to be announced to the Tier 1 reps. It IS a problem.

Thanks in advance,

Rob from AZ

  • Okay, so I called Apple about this latest development and this is what the representative told me (paraphrasing):

    "Apple acknowledges there is a problem and they have narrowed it down to "just a few" providers - not just Cox. The engineers are aware of this issue and they are looking into it. We no longer report this issue to them because they are already working on it."

    I asked, does this mean that Apple is attempting to fix the problem, that it is not just a case of "it's the providers' fault and we can't fix it"?  The representative said "Yes". 

    So, take that for whatever it's worth. After all, I was told last summer that "the engineers are looking into it" and nothing came back but fingerpointing at Cox. So let's hope that what I was told is in fact the case, that they are looking into it again with the intention of fixing it.


82 Replies

Replies have been turned off for this discussion
  • ChrisL's avatar
    Former Moderator

    It sounds like from what you've been told the issue likely lies with the Mac Mail client on the mini as how it works with the phone.  IMAP doens't do push and relies on the mail client to periodically check for email updates.  I would suggest asking them again if there is a way to setup the email on the Mac Mini to behave more like the iPhone.

  • ChrisL's avatar
    Former Moderator

    Could you also verify what versions of Mac Mail and Mac OS X you're using as well?

  • AZrob's avatar
    New Contributor III

    I am running OSX 10.8.4, and the version of Mail is 6.5 (1508).

    I don't think I was clear enough about what the Apple Mail support person told me. He said that what is happening is that the IDLE option is being forced on for all Mac Mail configurations. In IDLE mode, the client is continuously connected to the mail server and the mail server pushes incoming emails immediately to the client. There is no waiting for the client to query the server at a set frequency, say every 5 minutes. The server sends it as soon as it gets it.

    And all would be well if COX supported the IDLE mode for IMAP, but apparently COX does not. So the Mac client is waiting in a configuration for mails to arrive but the COX server doesn't send them on its own. like it should if IDLE were working.

    If we could take the client out of IDLE mode, things would probably work okay - IDLE is not required for IMAP to work. But when you configure a Mac Mail client for COX IMAP, the box for the option "Use IDLE command if the server supports it" is checked and the whole option is greyed out. So you can't change it and therefore you are stuck in IDLE mode. This does not happen with all email clients connecting via COX IMAP, but it does happen with every Mac Mail client. or so I am told.

    I imagine there must be hundreds of Mac Mail users on COX now who have this issue, although the rollout of IMAP is so new, my posting seems to be the first one on this forum. If anyone else is having this issue, please chime in.


  • Trikein's avatar
    Contributor III

    First, just to be clear, your using IMAP for on a Residential Internet connection yes? I am assuming this isn't business related. To be honest I didnt know Cox had IMAP on the Home side.

    The Mac Mail Client is horrid. Its one of the reasons Thunderbird has become so popular over the years, because just like PC users immediately change browsers, Mac users (in the know) switch email clients. I know this doesn't solve your problem, but it should me noted. There are alot of free email Apps for the Ipad.

    More to your OP, is Idle mode greyed out during the config Wizard or at all times. Try to go in and disable after?

    1. Select "Mail | Preferences..." from the menu.
    2. Choose "Accounts".
    3. Select the desired IMAP account.
    4. Go to the "Advanced" tab.
    5. Make sure to uncheck "Use IDLE command if the server supports it".

     If it won't let you pass the wizard, maybe try setting it up with a Gmail account and then go in and disable Idle and change the IMAP and SMTP settings? Also I found this interesting thread. Note that even when it works, its buggy, though that may have been patched by now. 

  • AZrob's avatar
    New Contributor III

    COX just made IMAP available to Residential customers a few weeks ago. In fact, it may be, and I am hoping, that this problem is due to the fact that Cox just rolled this out for us non-Business people and that they missed something in the process. 

    When I go to the Advanced Tab, the IDLE option is checked and greyed out. You can't get to it.

    I did try the suggestion that was in your link to fake an account with a false email address, which gets you out of the Wizard. Then I was able to set up a real account without the IDLE checked.  Eagerly I awaited the immediate arrival of a test email.

    It didn't work. So now I question whether Apple is correct when they say this is a matter of getting the client to have its IDLE option unchecked. Because thanks to you I have done it, and I still can't get incoming mail unless I take the account offline then online.

    I was wondering whether that was the problem because I noticed that Outlook for Mac works with COX IMAP whether or not you check the IDLE command.

    So now I am going to go back to my support person at Apple and report this behavior.

    Either way, I have to believe that there are many Mac users out there using Mac Mail who thought that they could now get IMAP via COX - but still cannot. The other aspects of IMAP work I'd like to stick with it and hope they'll fix it soon.


  • Trikein's avatar
    Contributor III

    So let me restate some facts and questions to flesh out the problem.

    1. Problem is with receiving, no problem sending. This rules out account, user/password,etc.
    2. Problem is specific Push functionality. The emails download if you enable/disable. This rules out Basic IMAP/SMTP settings.
      1. Could you give more information on when you said: "He said that what is happening is that the IDLE option is being forced on for all Mac Mail configurations." Do you mean Cox is forcing or Apple is forcing?
      2. Did Apple provide you, or show you how to find, any error report from the Ipad Mini email client?
      3. Do you have SSL enabled on IMAP? If so, what port does it default to?
    3. Problem is with Ipad Mini only, works on Desktop Outlook and Iphone Mac Mail, even with Idle both on/off. This rules out basic IMAP implementation.
      1. Is your Ipad Mini Wifi only or Wifi/Cellular?
      2. If Wifi/Cellular, what carrier?
      3. What firmware/software version is it using? Have you tried updating it?
      4. Are there any other different/new/missing Options between Ipad Mini client and Outlook for Mac?

    I have a feeling the problem may be the "Idle Mode" box doesn't force Idle, it just allows it if the server is capable. This is similar to their SSL implementation, so that would make sense. Now if Apple says (and correct me if I am misquoting) that they are forcing Idle, it would make sense that their latest product would disable the "Idle Mode" option because it is being forced. Its also possible Cox has purposely not implemented Idle mode because of the additional bandwidth it would consume on the server. As you said though, it could just be something they have disabled until they have the server running on full load. If that is the case, I have 2 ideas, but I have put myself out onto a pretty long hypothetical branch, so I tend to want to wait on a official Cox statement. But since I am a nerd...

    1.  Does Apple's Cloud service force Idle if you sync your Cox Imap account with it? And then just load that account via the cloud onto the Ipad Mini. Warning though; I have seen this cause other problems, but its worth a try.

    2. Have you tried another Ipad Mini Email app? If all your accounts are Gmail, I would try the Gmail App. If not, but all your accounts are Imap, try the Incredimail App. Also "Mailbox" seems to be a popular one, but there doesn't seem to be a Ipad specific App, only Iphone. Also it seems they don't support POP3. ::Le sigh::

  • AZrob's avatar
    New Contributor III

    To answer your questions, Trikein,

    First of all, I am talking about problems with my two Mac Mini's, mine and my wife's. The iPad and iPhone mail works fine.

    The Apple Mail support person implied that Cox was forcing the creation of IMAX accounts that were automatically set to use the iDLE mode. You cannot normally uncheck that mode because it is grayed out.

    However, taking a hint from one of the links above, I was able to create an Apple Mail account that did NOT have the IDLE mode checked - and I still have the problem. Also, I note that Outlook for Mac works with IDLE on as well as off. 

    So I am not sure if either I did not understand the Apple person as to what their diagnosis was, or they are simply incorrect. I have another call in to Apple pointing out my findings and asking for clarification from their engineers. 

    I'd like to stay away from putting either iCloud into the picture or other mail clients - I really want this to work with Apple Mail. My wife is used to it from her iPhone and iPad.

    What i'd really like to see here is someone from COX stepping up and talking about this issue. It seems to me pretty major if Mac users can't use Mac Mail properly when connected to COX's new IMAP offering. Especially since now when create a new email account, it assumes you want IMAP and that's what you get. POP is no longer the default option.

    Rob from AZ

  • Trikein's avatar
    Contributor III

    Ahh ok, when you said Mac Mini I thought you were talking about a Ipad Mini and using the wrong word. The exact same account works fine with the Outlook client, but not the Mac client yes? That alone rules out Cox. But then on top of that you tried another, non Cox Imap email, with Mac mail and it also didn't work. It sounds like Apple's mail is Forcing Idle mode, something Cox's Imap does not support. You even have Apple confirming this when you talked to their engineer. So we know what the problem is.

    I see you have 3 options.

    1. Try to either get, or wait until, Cox's Imap support Idle mode.

    2. Use a non Cox email.

    3. Use a Non Mac Client. Like Thunderbird.

    I have had personal experience with helping my mom setup email on the Mac Mail client for iOS and I loath it. It downloaded all her email off the server even if I specifically told it to leave a copy. Would only happen on first sync. Any additional email I sent, it would download and leave on server, but first sync it downloaded it all, making it impossible to download onto her PC. Other then resend 2000 emails to herself, there was nothing we could do.

    And thinking about it, I think I know of a really good reason why they don't enable Idle Mode. I don't know if its the actual reason, but it makes sense. Usually with any other email account, you have to either pick POP or IMAP. That is because with most other IMAP, that Idle mode creates a constant connection with the email server, keeping other clients from requesting mail via Pop. Think of the email server like a phone number, if you call it and keep the line busy, anyone else calling it will get a busy signal. Maybe thats why Cox disabled it, because they know the majority of people wanting to use IMAP will already have that account set up for Pop, and if they enabled Idle Mode, the customer setting up Imap would be breaking their email. However that very fact may give us a work around. Have you tried setting up her account on the Mac Mini with Pop?

    So Cox has several valid possible reasons, to conserve bandwidth (which they cap) and to create broader compatibility. What reason does Mac give for requiring Idle? Sounds like its Apple being stubborn and forcing something upon their user base because they think they know best. This is common with Apple and why I try to stay away from their software. But thats just my 2 cents.

  • J_C_'s avatar
    New Contributor

    I am having the same problem as you, Rob,  except I am using an iMac also running OSX 10.8.4 (Mountain Lion) and the same Apple mail program. I can send mail, but not receive any without either closing the mail program or going offline and then back again. My Cox mail worked fine for about two weeks on this new iMac.

    I have another iMac running OSX 10.7.4 (Lion) and I set up my IMAP Cox email on it to see what would happen. It also would not receive any mail.  What is interesting is that my wife's Cox email account that was set up as a POP account last year on this same iMac (running Lion), receives and sends mail without a problem.

    Apple has acknowledged this problem with some IMAP Cox accounts set up using Apple Mail. Cox claims there isn't any problem. The Apple representative told me that there may be a solution to solve this problem with Cox. He said to call Cox and ask Cox to reset the account and password internally, with their server. Not what you can do by going online. He said that this has helped some people he has spoken to with this same email problem. I have not done this yet.

    Another solution is to set up a gmail account, add it to Apple Mail and have all your Cox mail forwarded into it. You will find the settings to forward mail in Cox Webmail, message settings. This does work as a work-around solution. Another work-around solution is to add a Go Offline button to your Apple Mail toolbar. (This button is in customize toolbar. Just drag it to the toolbar).  Click it to go offline, then click it again to go online and your new mail will be received. 

    I agree that this is a problem that needs a solution.

    Jerry from VA

  • Trikein's avatar
    Contributor III

    The solution is for Apple not to force Idle mode. The people running the server should make the call on how to implement certain things, not the company making the software. 

    And what malarkey is "resetting the password internally". I think thats basically Apple saying they believe some of the problems is user error. Not in this case of course, but I just find it funny. Sounds like a Snake Oil fix to me.

    With that said those are good workarounds. The forwarding doesn't quite work because Gmail doesn't allow proxy. Maybe have Gmail as incoming and Cox SMTP as outgoing, but you would have to set it to use username/password on outgoing. This might cause some problem with attachments and Spam so it isn't a perfect solution. Still pretty decent though.

    I just want to hear Apples reasoning for forcing Idle. It wasn't something they forced with previous versions, that is why the option is there in the first place.