This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Is there something wrong with the Cisco Explorer 8642HDC Firmware

I recently had the trusty Scientific Altanta DVR replaced after a Service Call about being unable to view ON Demand movies.

The new Cisco box worked ok for  few days until we tried to view a recorded program. It stuttered and was generally unwatchable on the playback. That started to occur watching live TV too. Was this a bad disk? Another symptom was that viewing the guide shrank the live TV picture as expected, but when exiting from the Guide, the picture remained small in the upper right quadrant. Changing channels didn't reset. A complete reset by unplugging power was the only way to get it back. The continued playback stutter made me visit a store for an exchange.

The second unit seemed OK, but suffered from the same stuuer playback. I left the stuttering program on what I thought might be bad disk, and subsequent recorded shows seemed fine. This morning I noticed the program playing through this box, was about 5 seconds delayed from the same program playing through a non-DVR box, where previously they had been in perfect sync. I clicked the guide, and the same shrunken picture state happened.

I have been searching issues with the Cisco boxes and the stutter is mentioned a lot.

Is the box subject to overheating - it is in a cabinet with glass doors.

Can I get a Scientific Atlanta DVR Cable box. I am seriously considering a move to satellite

  • Hi there, I sent you a private message asking for more information.

  • I have not received your private message. I would be glad to provide more information. A new problem has now occurred. Recorded programs are not viewable as the DVR suggests that a connected external device (disk?) needs to be connected. I assume it thinks I had a SATA disk attached at some time and that is now disconnected. I do not have such a device.

    Please contact me so that I may answer your need for more information.

  • Mine is doing the same thing. The have replaced my DVR twice. I was told that there is going to be an update to the firmware or something with no estimated time frame of when it was going to come out. It is very frustrating to be paying for this service and not being able to use it completely.

  • I spoke with Cox Support and indeed they know about this problem and say a fix will be pushed out to the boxes some time in the future. I was directed to apply a temporary fix:

    With box and TV on do the following:

    1. Press the 'settings' button on the remote
    2. Choose Adnavced setting
    3. Scroll down to Accessories (last item in list)
    4. select
    5. Select Disk Power
    6. Set to Always On
    7. Set Power off to manual
    8. Save settings and Exit.

    The recorded programs still seem to be inaccessible, but we will see if future recording will be available.

    I will post updates in a few days.

  • on 8642's the hard drive may try to go into power save mode during playback of a DVR recording. Causing tiling during dvr plackback

    To fix the tiling issue:

    1. 1.       On the remote for the 8642 DVR, press the Settings button. Then press the A button.
      Result: the Settings menu displays onscreen.
    2. 2.       From the main Settings menu, scroll to and select the Accessories option.
    3. 3.       Scroll to and select the Power Management option.
    4. 4.       Set Hard Drive Power option to ALWAYS ON.