One TV doesn't get all channels

One TV doesn't get all channels

TV Forum

Activity: 8 Replies | 2 Subscribers

This question is still unresolved
Posted by

We have 2 TVs with cable boxes.  The "main" TV gets all of the channels we paid for.  The secondary TV used to get all the channels too but within the last week has dropped some of the channels.  When I enter a channel it used to have, it doesn't go to that channel.  

All Replies
  • Posted by JonathanJ
    8 Aug 2017 9:58 PM
    @sahmat

    Please email full address and primary name on the account to cox.help@cox.com so we can take a look.

    Jonathan J
    Cox Support Forums Moderator

  • Posted by Sully734
    12 Aug 2017 7:36 PM

    Having the same problem here.. what did they tell you?

  • Posted by ReneeG
    12 Aug 2017 7:43 PM
    Hi Sully734,

    We're happy to investigate this for you. Have you tried resetting the receiver by unplugging the power for 2 full minutes and then plug it back in to see if that helps? Please send your account details to cox.help@cox.com to allow us to check this from the office.

    Renee G.
    Cox Support Forum Moderator

  • Posted by sahmat
    13 Aug 2017 5:53 PM

    I tried the suggestion for you to remove power but that didn't work.  I'm sending the email.  

  • Posted by La23cat
    14 Aug 2017 4:26 PM

    I have been having the same problem with my cable tv also. just found 1 of the 2 wont receive anything above chanel 100

  • Posted by sahmat
    14 Aug 2017 5:52 PM

    Still trying to get resolution via email (I don't have time to sit on the phone with Cox).   Will post here if/when it is resolved.  

  • Posted by CarolLM
    14 Aug 2017 7:14 PM

    Hi, please send a private message via Facebook, a Twitter direct message, or an email to cox.help@cox.com.  Include your complete address, account name and the specifics of your concern.  We'll take a look to see what's going on.  Thanks 

    Carol - Cox Support Forums Moderator

  • Posted by sahmat
    18 Aug 2017 10:08 PM

    I've been corresponding with Cox about this issue and the latest email stated that minis don't get all stations.  I know that isn't true since it did have all of the stations shortly after installation.  I'd appreciate working with someone at Cox that is willing to resolve this issue.  This is not acceptable.