This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Can't connect to Cox smtp server

All of a sudden, my MAC won't connect to Cox's SMTP outgoing mail server. I've disconnected, restarted everything. Talked to an oh-so-not helpful person at Cox and still it won't work. Incoming mail is fine; just can't send. All settings are to Cox's instructions. It's worked fine for more than a year and then just stopped yesterday. HELP!

  • Are you getting any kind of error message when you try to send?  Which settings did you use?  Are you using your home Cox Internet connection to send?

  • Yes. The message says connecting to the server failed. 

    Settings are default port and SSL is checked. 

    This is through the home Cox internet connection.

  • We are experiencing the same problem, we have 3 email addresses under one bill, and we cannot send emails either, we called tech support 5 times, each time we were put on hold and then disconnected. When we finally got through to them the not-so-helpful person barely said a word and said her server was down. I was able to get on a live chat with little to no progress, and when it did seem like we were making some progress our internet connection went out and when it came back on I was no longer in the live chat (don't think it was a coincidence on their end).

    The error we keep receiving is

    There are several reasons why this may have occurred: 1) You may have exceeded the allowable sending limit via WebMail. If you have knowingly been sending numerous messages within a short time period, you may be blocked from sending additional messages for a period of three hours, at which time the block will be automatically lifted. 2) The content of your message may be considered spam by our anti-spam systems, and has therefore been blocked. Try sending an empty test message to yourself to see if you can receive it. If you receive it, this would indicate that the blocked message is considered spam. Please visit http://coxagainstspam.cox.net for more information. 3) There may be a temporary system problem or maintenance which is causing the failure. Please visit http://status.cox.net for current information about such issues. In this case, the service will be restored as soon as possible.

    1) we're not sending spam, not even forwarding anything with links

    2 ) I only sent 3 emails all "test" emails in an hour and the chat person said we were exceeding our sent messages limit

    No one seems to have an answer, when I asked if something was wrong with a connection setting such as SMTP they had no reply

  • I'm experiencing a similar problem -- it has recurred off and on for the past two weeks. I get this error message:

    An error occurred sending mail: The mail server sent an incorrect greeting:  eastrmimpo109 cox ESMTP server temporarly not available.

  • I am having the same exact problem (same error code as the last person that replied). Tech on the phone (after being on hold forever) told me that I just needed to reset my account in my email program - should have tried that while I still had him on the phone. I got off the phone and reset my account like he said to do -- didn't help. Only thing that is working for me is to leave the emails in the outbox and they eventually send when they feel like it!