This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

CG3000D

I just got a netgear CG3000D modem/router from Cox. It has a USB port, which is, in theory, suppose to work with a external drive or printer. Neither works. Nothing is mentioned about the USB port in the Cox supplied documentation. In an internet instruction (not from Cox, from Netgear Australia), the CG3000D instructions mention that the USB port may need updated firmware to work. My conclusion is that Cox provides a version of the CG3000D that does not allow enabling the USB port. Anyone have experience with using an active USB port on the CG3000D from Cox? I assume the USB port from Cox is useless.

  • Just as a followup, I checked and I can buy a Netgear modem/router at Walmart, either N600 for $149, or a N300 for $119, both which have a working USB port for sharing files on their "Readyshare USB port", on an external USB drive. The N600 is dual band. So I am wondering now if I ought to just return the CG3000D to Cox (which cost $129), since it seems to have limited capability compared to the other modems available elsewhere. I have 30 days to return it. The Cox help support I called didn't know anything about the USB port on the CG3000D. So the advantage of having a Cox supplied modem/router (with their support) is rather useless. Will think about it.

  • The benefits of getting the CG3000D from us are that you're getting a managed home networking solution supported by us.  It is my understanding however that the USB host port that you're referring to is indeed not enabled or supported at this time.  If this is a critical feature requirement for you the option of the stand alone router probably makes the best sense at this point to meet your needs.

  • The USB port isn't a critical feature for me. I am going to see how the wireless on the CG3000D works, in the next month (reliability, performance) before I decide to keep it or not. I was just disappointed that a feature shown on the unit doesn't work. Just as a suggestion, you should send a memo to the support phone help people at Cox..saying to tell people the USB port is not enabled, if they ask about it. I need to check out the two Cox network tools provided on the web too. The last time I checked, they didn't work. But that may have been because I was using Chrome instead of IE.

  • OK. Had the CG3000D for about a month. It works OK. I'll be keeping it.

  • I also tried this modem brand from Cox and they worked fine besides I am planning to upgrade my internet plan to a much higher speed which Cox requires a DOCSIS 3.0 standard. Before the 30-day period I returned the modem and bought one from eBay for $61 only.