Roku devices CONSTANTLY getting disconnected from internet

For the last few weeks, all of my Roku devices have randomly disconnected from the internet at once at least 2-3 times a week, and at random times of the day (even mid afternoon).  I have them skewed throughout the house on different Tv’s, and even set up a WiFi extender.  The odd thing is that none of my other devices (laptop, 2 phones) are affected by the loss of service.  The only remedy is to keep rebooting the modem, but I don’t think it’s necessary to power cycle the modem constantly.  It’s getting ridiculous.  Should I swap out the modem (it’s a Panoramic through Cox) for a new one?

  • Hi JP Sports,

    If you are having difficulty keeping a consistent connection with your Roku devices, you might want to consider the location of the Panoramic WiFi Modem and wireless extenders should be placed in a central location in your home away from interference.

    For optimal performance, place the equipment in a central location where the devices will mostly be used. An elevated location, such as a higher shelf, where laptops have a line of sight view. The WiFi modem should be in a vertical position.

    Areas to avoid would be near other interference sources (such as microwaves, high powered appliances, 2.4 GHz cordless phones or other wireless devices close to other Wireless Access Points), basements, next to other wireless routers, near metal objects and surfaces against a wall, tucked away in a corner on the floor or behind the furniture, near windows or close to halogen or fluorescent lighting.

    www.cox.com/.../ways-to-improve-your-in-home-wifi-network.html

    Maria L.
    Cox Support Forum Moderator
  • Do you have a TV in the same room as the modem? If so try hooking it via ethernet and see if it is effected when all the others are. By the way, how many Roku do you have?

  • I wouldn't swap anything until Roku patches a new vulnerability with streaming-media devices (Chromecast, Google Home, Roku, Sonos, thermostats).  One of its many potentially malicious acts is to provide a denial-of-service with Roku.

    The vulnerability is called DNS Rebinding and it exploits the "implicit trust" between all devices on your personal network.  For example, if you want to control your Sonos with an Android smartphone, Sonos will implicitly trust the smartphone as long as it has an IP address from your home router, which would be a private IP address.

    Basically, a malicious ad loads on a web page.  No big whoop because your safe-surfing habits prevent you from clicking it.  However, when the ad loads, it makes a DNS request of a [malicious] website.

    The way DNS works is if the Cox DNS can't resolve a URL, the DNS process will find the "authoritative" server hosing the domain of said URL.  It's a legit name-resolution process and we use it every day (forums.cox.com = 184.106.13.9).

    Although it's legit, the [malicious] authoritative DNS server will eventually point the ad to a random private IP address and if your router uses that range of addresses, every device on your network will implicitly trust the ad.  The ad could then connect to other devices on your network with malicious intent or start shot-gunning known factory-default usernames and passwords at your router.  Change those defaults!

    Anyway, Roku is pretty good at pushing its updates; however, they may have yet to fix this vulnerability.  Change the defaults on your rooter, if required...disable its UPnP, if required...and keep an eye on updates.

    If you still get DoS after Roku patches their devices, you should review your logs to troubleshoot the disconnects.

  • After power cycling the modem, all devices wouldn’t connect.  After 1 tech call, I went to the store and swapped the modem.  When I got back, even after setting up the new WiFi, there was still no internet connection on any device, plus my landline was down.  Long story short: it ended up being a faulty cable from the outside box to the router, but even after that, the Roku couldn’t receive a strong enough signal despite my (and the tech’s) phone showing a very strong signal in the same room.  So I replaced the stick with a box and all good since.