This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Can't send emails from iPhone when connected via cellular network

Ever since the recent changes made by Cox to the email servers I am unable to send email from my iPhone unless I am connected to WiFi.  All of my settings are correct (since I can send fine if I am on my home WiFi or WiFi at my office).  As soon as I disconnect from WiFi and try to send mail while connected to the AT&T cellular data network, all outbound emails just get stuck in the Outbox and will not send.  Per the suggestion of telephone support I tried changing the port from 587 to 465 but it made no difference.  Telephone support suggested that it must be an AT&T problem and I should contact them, but I have multiple other email accounts on my iPhone that use port 587 for the SMTP server and they all work fine.  I have also seen reports by other users on this forum that they are having a similar issue with phones on Verizon.  The fact that this issue exists across multiple cellular carriers and started exactly when Cox made "upgrades" to their email servers indicates that Cox is responsible for the issue.  Someone at Cox needs to actually look into all of these issues that "coincidentally" appeared exactly when Cox made changes to their email servers, rather than just blaming users or other companies.  The only actions that seem to be taken upon multiples users reporting issues are suggestions to "change your password" or "check to make sure your settings are correct" or "just use webmail instead".  None of these are valid or helpful answers.  My password and settings are correct and I am able to send email just fine when connected via WiFI, but I should be (and always have been in the past) able to send emails just as easily when connected to a cellular data network.  Using Webmail on an iPhone is cumbersome and not an acceptable substitute for the native mail app.  

I have been a Cox customer for 18 years, and have never had any issues until the multitude of problems that have occurred over the past several months during which Cox has been "upgrading" their email.  In addition to my current problems with sending mail from my iPhone I have also experienced at times: delays in receiving mail, delays in sending mail, emails sent to other cox customers that never arrived despite being in my sent items folder with no return error messages received (also reported by others on this forum), not to mention the annoyance where Outlook keeps randomly asking for the password to check email even though it already has the correct password.  All of these issues have been posted on these forums multiple times by different users, but Cox support seems unwilling to accept any responsibility or take any action.  

I was practically begging a phone support rep to look into my current issue and/or kick it up the chain to get it solved, but he just said "Nope, sounds like an AT&T issue so you will need to bring it up to them".

What do we have to do to get Cox to acknowledge and look into solutions for a serious issue, rather than just dismissing, blaming others, or offering laughable "solutions"?