This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

High jitter and constant "service interrupted" on account dashboard

For the past couple months, I've been getting high ping jitter and rubberbanding in games throughout the day. Multiple Cox techs have visited my home and verified everything on my side is working fine. The issue occurs on all my devices and I have changed different cables, modems and routers to no avail. I am the only person in the household. I also have a constant message on my Cox dashboard saying "service interrupted".

Calling Cox has been useless as everything they say is contradictory. Live chat tells me there's an issue with my connection, tech arrives and tells me everything is fine. Competitive gaming is almost impossible at this point as I rubberband every few minutes with my "fine and working" internet connection.

Parents
  • I've been having the same problem in Las Vegas. I'm paying for both Gigablast and the $50 unlimited data plan (which really isn't unlimited by the way - it still throttles your speed when you reach your data limit - the limit is just higher) and I've been having the same random spikes in lag as well as disconnects. It affects everything I'm doing on the Internet. Streaming movies will suddenly say I've lost my Internet connection and the connection doesn't come back for 5-10 minutes. Large downloads have been interrupted. Web site pages won't load. All of my Amazon Echo devices complain that they have no Internet connection. When I check my Cox status, it always says "Service Interrupted." I've checked equipment, cables, configurations. I've reset modem, routers, switches, and client devices. I've used network test equipment and software on my local network. I've used an Ethernet cable tester on all of the cabling in my walls. The elimination of all possible on site causes indicates a problem in the Cox system, whether it's their demarcation cabling to my home, a damaged underground cable, or a faulty switch in their data centers. They need to do as much thorough testing on their equipment and cabling as I did on mine.

Reply Children
No Data