Cox Ultimate internet Package Speeds are very slow

Hi all,

I have the Ultimate package and my internet speeds are very slow ~20-22 upload and download. Purchased a new modem which is listed on the Cox Certified Cable Modems page and had Cox cable run new cable from the pole to my house with very little change in my speeds when tested. All testing is performed by directly connecting to the router and not using the wifi. Other test I changed out the cat6 ethernet cable and retested with same results. Listed below are my specs on my setup. Just not sure if my connection issue goes beyond the pole or on my end. Any input would help.

1. Netgear - Model C6300  /  DOCSIS 3.0  /  16x4 channel

2. Lenovo Thinkpad  /  win10 64 bit  /  16 GB memory

3. New cable from pole to my house

thanks,

Abom

Parents Reply
  • e1500

    Yea, that would do it. Not only was it double NAT, but the E1500 only had 10/100Mbps ports. That's why it was hurting your upload and download.  Plus it's very old, so the wifi isn't very good at all. 

    Glad your speed is good. Now just watch for consistency. Think of it like a highway. The more lanes, the more cars can be on the highway before there is traffic. If you have 16 "lanes" on your modem, you might see a problem as those lanes fill up. Might not. Depends on how many people are in your area and what they use the internet for. If you do, I would suggest a upgrade to a modem like the Netgear CM600 and a new stand alone router. Work horse is currently Asus RT-AC68U. Can even get one for free if you have Tmobile. 

    For now, I am going to mark the double NAT post as solution. First time seeing how the solution system works since the forum redesign. Cheers!

Children
No Data