This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Unable to Connect to Server to check email on Android phone

Having issues of being unable to access my Cox email account from my Android phone, getting an error message that says: Cannot Safely Connect to Server.  I have checked my Mobile / Secure Email Settings.

 My Incoming Settings are, the port is 995, and security type SSL.  

My Outgoing Server Settings are, the port is 465, security type SSL.  

When going forward the following message is displayed:

Setup could not finish

Cannot safely connect to server.


Trust anchor for certification path not found.)

........Exactly as stated in another user's question from 2/18/12.....and this has been happening to me the week of February 12 to currently as I send this February 20, 2012.

Does the "east" need need to be removed from the Incoming and Outgoing Server Settings???  This is very inconvenient without any warning as a Customer.

I see one other user / customer with the same issue.  Any solution yet other than as mentioned in settings? 

  • I am the above user having the issue with a Samsung Android Transfix and I have Cricket service.  I saw 2 other forum users having the same trouble.  I read the article on the website which says we should not have to make any changes.....leaving it as was and allowing time to pass did not cause the problem to fix itself......or to be notified by Cox in ANY way shape or form as a Customer.  

      I then went and removed the word EAST from both my INCOMING and OUTGOING server settings, and am NOW ABLE to refresh mail and have NEW email show in my INBOX.

    I advised another forum post to try the above as it seems to have solved the Server Connection issue for me.  I sure wish that someone from Cox would have sent information out to its customers that there may be an issue instead of letting us think it was most likely our mobile service provider.  A little heads up would be greatly appreciated in the future.  

  • I have experienced problems with my cox email account on my android phone like so many others.  Unfortunately, Verizon only offers many users the choice to select - no option available to change settings manually.  I've been to Verizon twice and was told most recently the Cox wireless mail server was down.  While this may be true today I find it hard to believe the server has been down for 4-5 days.  I shared the new server name with Verizon but they were unresponsive because the wireless server was down.  Would someone from Cox please communicate with Verizon to update their business rules to reflect the new server name so that when the server is available service can be restored. 

  • I had the same issue on my android tablet and android phone, this worked for me.

  • This doesn't really have anything to do with your phone as it does Cox service, as I used to have the same problem with my iPhone and laptop when away from home.  

    Cox email servers prefer to be 'hit' from your in-home account as verification that it's you.  What I ended up doing was using a mail RELAY service such as this  For a cost of $1.50 per month for up to 150 relays per day, your phone uses them as the smtp address to send mail to which they relay to Cox using your login credentials.

    As far as smtp.west.cox is concerned, the emails are coming from you when you're home.

  • It should not be necessary to use a relay server in order to get this working on your phone.  The following settings *should work.  I say should because one of the stock apps provided with some older android phones would not work with the configuration below.  Some customers found that loading a different email application from the Android market resolved the problem for them.  Note that that settings below should allow you to send and receive email while off the Cox network.  I can attest to this working fine on my HTC Amaze.

    We have information available on our support site as well here:{a8fb24c0-6440-11df-ccef-000000000000}


    username (without


    port 995




    port 465


    and require sign in if you have that option.