Email security settings

Email security settings

Internet Forum

Activity: 11 Replies | 6 Subscribers

This question is still unresolved
Posted by

Hi,

I received an email from "Cox" today. Here is part of text. Is this real or bogus?

Thanks,

Bill 

"As part of Cox’s ongoing efforts to safeguard our customers’ information, we have identified that you are using outdated email security settings. 


To strengthen the security and privacy of your Cox.net email account, it is essential you update the settings by January 25, 2018 on the devices you use to access the following Cox.net Email(s):

email address' listed here...

These settings control how email messages are sent and received
by your Cox.net Email. They were likely set up years ago and do not
meet newer industry standards. Because your Cox.net Email
settings are unique to your individual email programs on your
devices such as your phone and computer, Cox is unable to make
the changes on your behalf.

For your protection, after January 25, 2018, any devices with outdated settings will no longer be able to send or receive messages from your Cox.net Email until the setting changes are made. "
All Replies
  • Posted by MaryF
    10 Jan 2018 1:47 PM

    Hi wmars1776,

    The email that you received is legitimate.  If you have any other questions or concerns, please let us know.

    Mary F.
    Cox Support Forums Moderator

  • Posted by Derral
    11 Jan 2018 10:50 PM

    I've tried changing Mail, Outlook, and Airmail smtp port numerous times to 465 only to have no emails being sent.  I've tried updating each program with 993 and 465 for IMAP but I've gotten the same result:  I can receive emails but can not send.  The only reason my smtp port is set to 25 (Unsecured) is to be able to send emails.  It's interesting that I'm having the same issue with all three programs but not with Webmail.  NO, I don't want to use Webmail instead of Outlook.

    This is an issue that COX has known about for years.  Just because Cox tells us to change our settings by January 25th 2018 is not going to magically make Mail, Outlook, and Airmail start sending emails.

    Better Cox support to fix this issue is needed.  I've changed my settings to 993 and 465.  Now that I've updated the ports is Cox going to ensure I can receive and send emails?

    Cox customer for over 25 years.  But maybe for not much longer.

    Derral Howard

  • Posted by Allan
    12 Jan 2018 3:24 AM

    @Derral

    We can look into this ongoing issue for you. Please send us an email with your full address and the email account you are trying to access to cox.help@cox.com.

    Thanks.

    Allan - Cox Support Forums Moderator.

  • Posted by Bigbamboo
    12 Jan 2018 6:43 AM

    I'm having the exact same issue.  I can receive, but not send.  So for now I have reverted to the non-SSL settings in order to send email.  Using Windows Live, and I don't want to use Webmail either.

  • Posted by StephanieA
    12 Jan 2018 7:10 AM
    Bigbamboo,

    What are your current settings for your out-going server?

    Stephanie A
    Cox Support Forum Moderator

  • Posted by summersun
    12 Jan 2018 7:51 AM

    I also received the email to change my settings last night. Just changed them in my outlook and having the same issues, no out going mail. Current settings are now "25" outgoing mail server and "995" incoming mail server. Changed back to 25 otherwise like everyone else on this post would not be able to send mail. Also not going to use webmail.

  • Posted by Fortsand
    12 Jan 2018 6:53 PM

    I received the same e-mail and I have changed the settings on my PC.  I use Windows Live mail on my PC.  Now that I have made the changes, sent messages are not going out and I am not receiving.  My iPad and Android device seems  to be okay.

  • Posted by Chris K
    12 Jan 2018 7:39 PM

    Have you tried going to ougoing server tab and checking that the outgoing server requires authentication? 

  • Posted by ColleenD
    12 Jan 2018 8:10 PM
    Hello everyone,

    Please follow the guided help at www.cox.com/secureemail from start to finish. Not completing all steps can result in errors.

    ColleenD 
    Cox Support Forums Moderator

  • Posted by bryaninphx
    13 Jan 2018 1:32 AM

    Chris K

    Have you tried going to outgoing server tab and checking that the outgoing server requires authentication

    Go to the Servers Tab and check the box circled in Orange Below

    Phoenix, AZ - TiVo Bolt, Roamio Pro, XL4, Minis

  • Posted by Papa Joe
    16 Jan 2018 9:52 PM

    My problem with Microsoft Outlook email is that when I go to the in and outgoing area I do not see numbers for settings - only, pop 3 language i.e., settings equal incoming = pop.cox.net  outgoing = smtp.cox.net.....where are the settings 110

     and 25?? Do you put the new settings where the pop and smtp settings are?