Problems with New Cox Webmail interface

Problems with New Cox Webmail interface

Internet Forum

Activity: 16 Replies | 4 Subscribers

This question is still unresolved
Posted by
First, the new webmail loads EXTREMELY slow! I have tried from different computers at different locations, and it is always SLOW. If I use the new link "myemail.cox.net", some of my accounts do not load at all after I log-in )I just get three blinking circles). I am using Windows 7 and Internet Explorer 11. I found by accident that if I use "in-private browsing", then the other accounts will load (but still slow). How do I fix so I can just log-in normally? After getting logged in (If I get that far): 1 - Nowhere on the page does it tell me which account I am logged-in on. It used to say "log out Joe's email", for example. 2- All the messages are listed on one page. There is no way to Delete a specific message without opening it. If I click on it, it opens. There is no Check-Box like there used to be, so I can select and delete all the Spam at once. Only option is one-at-a-time, or "select all". Overall, I see absolutely no improvement with this new system. Please reinstate the old one that worked fine for years (except for the poor service between Feb and May of this year)
All Replies
  • Posted by MaryF
    24 May 2017 2:11 AM

    Hi Mh575,

    In regards to experiencing the slow webmail, have you tried clearing your cookies and cache with your Internet Explorer 11 browser?  Do you have another browser that you can try with?

    In regards to deleting specific emails and missing the check box, there is an option to change the message view so that you can select the email without the email opening.  You may change the layout of your messages to List so that you don't get a preview of the email you want to delete.  To get the List View, click on View located on the top right of your window, right above Sort By.  Under Layout, click on List.  Then, go back to View, under Options select the Checkboxes so it has check mark beside it.   This will allow checkboxes in the List view so that you can mark the emails you want to delete without opening the email.  Let us know if you have any trouble finding this message layout.

    Once your email account has been migrated to the new platform, it cannot be reversed.  I can share your feedback regarding the new Cox email platform.

    Mary F.
    Cox Support Forums Moderator

  • Posted by jgpullensr
    24 May 2017 6:26 PM
    I am having the same problems. I can't stand the new interface and want the old one back. NOW. This new one is a pain in the ****. First of all I have problems logging in. I keep getting some notice that tries to tell me that there have been too many login errors. I do a complete shut down after clearing out all the cookies, reboot and attempt logging back in to my mail. I GET THE SAME ERROR MESSAGE I HAVE BEEN GETTING MOST OF THE DAY. I see absolutely no improvement with this new system. Please reinstate the old one that worked fine for years. Anyone ever heard the old axiom "if it ain't broke, DON'T fix it"? The way things currently are I'd be changing services, but I can't do that. Cox is the only game in town if you want cable service. To repeat my self, I can't stand the new interface and want the old one back. NOW!!!
  • Posted by Westsiders
    25 May 2017 12:04 AM

    The troubles don't just end there.  IDs and passwords apparently are not shared intelligently among the various Cox services.  In fact, we can't even share them on our two Macs at home, six feet apart!  The online instructions for use of webmail (as with other services) are arbitrary, sketchy, and sometimes conflicting, depending on when they were written and posted and the technology available at the time.  We've just spent two hours trying to get everything in harmony and while we have no problems with our other email services and Gmail, we still can't get Cox email to work right.  And we're technically savvy. 

    No, please don't sic some helplessly confused chat helper on us!  Get the process right and then write it down clearly, for once and for all -- at least until the next tech takes over the responsibility, with some new tricks, and we have to do this all over again.

    As it is, Cox webmail and thus IMAP email from Cox servers remains inaccessible this evening.  We'll try again in the morning, but if it it's still out there, we will think seriously about getting service from alternative broadband services, which are growing in number and sophistication (as Cox is not).  5G wireless is just around the corner, within the next 18 months, probably sooner.  Keep that in mind, please.

  • Posted by Westsiders
    25 May 2017 12:22 AM

    A big PS.  We use Macs running the latest version of Google Chrome browser, which automatically updates its onboard Adobe Flash Player whenever a new version comes out.  So we were surprised when we tried to use Cox Enhanced Webmail and got this message:

    "Thank you for attempting to access Enhanced WebMail.  Your browser does not meet the minimum requirement of Adobe Flash Player 9 or higher.

    In order to access Enhanced Webmail, please visit   http://www.adobe.com/products/flashplayer to download the latest version of Adobe Flash Player.

    If you prefer to access your email using Classic WebMail, click on the button below."  (Shown here for illustration only:  if you click on the button, you will be taken to the "Classic WebMail" webpage -- and good luck with that.)

    So just be sure, we downloaded the latest version of Flash Player from Adobe's website -- and got the very same message again. Is anyone at Cox actually proof-testing the Enhanced Webmail using technology other than a PC and the Microsoft Explorer browser, a relic of the 2000s?  Seems not, else why would we be refused access to Enhanced Webmail (unless it can't work with Macs and Chrome, easily the most popular browser today)?  Wow, are things that addled at Cox?

  • Posted by Westsiders
    25 May 2017 12:46 AM

    Got the Cox email working.  It was an interaction among Cox, Apple iCloud, and the Chrome browser hanging things up.  Never would have solved it using Cox's online instructions:  they don't grok the iCloud, not even after about a billion iPhones have been sold that employ it.  Sigh.

  • Posted by JonathanJ
    25 May 2017 1:22 AM
    @Westsiders

    Glad you was able to resolve the issue please let us know if you have any other concerns.

    Jonathan J
    Cox Support Forums Moderator

  • Posted by PAJ
    6 Jun 2017 1:31 AM
    I'm running Windows 7 and IE11. Email has worked perfectly until this evening, when I started getting this same message. I have followed the link and downloaded 3 times, but cannot locate it on the PC ...AND...still getting this message. Classic email is archaic, while enhanced works fairly well but still behind the times. No prior notice of any changes, and your link doesn't fix the issue. Put things back the way they were or give clear and correct instructions!!!!!!!!!!!!!!!!
  • Posted by Becky
    8 Jun 2017 6:13 AM
    Hi PAJ,

    You mentioned a message with a web link. Was this an error message? What link was provided? Are you able to access your email this morning?

    Becky K.
    Cox Support Forums Moderator

  • Posted by whooosh
    2 Jul 2017 2:21 PM
    I have the same problem, but it won't open at all for me. Just 3 gray dots dancing around. I talked to some guy this morning and after he heard my problem, he asked what O/S I was using. I said IE. He told me to go online and download google chrome. I guess people with IE are just screwed. I hung up. Cox has a bunch of idiots working for them. I'm moving over to a yahoo account and dropping cox in the next day or two.
  • Posted by StephanieA
    4 Jul 2017 4:27 AM
    whoosh,

    We have discovered an issues with webmail and Kaspersky Antivirus. You have the following options to access your emails:

    -Disable Kaspersky when they access myemail.cox.net.

    -Access Cox Email via a third party email client.

    -Add the website to the Trusted Web Addresses list in Kaspersky with these steps.
    Open Kaspersky.
    Click Settings.
    Click Protection on the upper left.
    Click Web Anti-Virus.
    Click Advanced Settings.
    Click Configure trusted web pages.
    Click on the Add button, then add http://myemail.cox.net and select Active.
    Click on the Add button again.

    Note: If necessary, repeat these steps to add other websites to the list.

    Close the Trusted web pages window.
    Click the Back arrow in the upper left three times to return to the main window.
    Retry accessing Cox Email.
    If the Inbox loads, all steps complete.
    If the Inbox does not load, close all open web browsers and then retry. All steps complete.

    Stephanie A
    Cox Support Forum Moderator

  • Posted by newine10
    25 Jul 2017 9:14 AM

    I agree. I've been on the phone with several Cox techs to assist with the new webmail interface but still producing the same results. Bottom line....IT'S JUST SLOW! As a matter of fact whenever I need to delete multiple emails I minimize the page to continue working on other things because it takes so dang long. Why would Cox install a new webmail interface when it doesn't improve user experience? It had gotten so bad I completely stopped using my Cox webmail account and started using Gmail exclusively.

  • Posted by JLC
    3 Aug 2017 7:08 PM

    I'm having the same problem. How did you resolve it exactly?

  • Posted by Jenskiaz
    31 Aug 2017 9:35 PM

    I have multiple Cox emails and there is only one that is in the new format.  I didn't chose it it just happened, the others are still the classic style and work far better than the new one.  Explain to me in detail how to go back and remember i didn't chose to migrate to the new format it just appeared.  Also If I have the choice when I sign in to pick enhanced vs classic don't tell me theres no way to go back, when obviously there is in other layouts.

  • Posted by JoePalmer
    1 Sep 2017 3:18 PM

    this new client is basically un-usable.  It defaults to clicking the top mail in the list and keeps that selected when you click any other message so you have to unclick it if you want to not do to it what you want to do to message you're selecting.  it takes forever to load.  Now every  time I try to send an e-mail I get back to the main screen then all of a sudden pop back to the e-mail I was sending with a time-out error.  I don't know if I've sent this message 0 times or 3 times.  You basically took everything that made the "enhanced client" worthless and made it even worse, and in the process got rid of the client that actually works.  Put us back to the "classic" (actually working) client until you make this new client work.  Better yet, dump the new client entirely, thin and fast is better.

    Here's the send error The connection to remote server 68.1.17.4 timed out while awaiting the response.

  • Posted by Becky
    4 Sep 2017 7:51 AM
    Hi Joe,

    Our developers are working to fix the issue where the first email in the Inbox is automatically checked. We don't have a release date yet, but the issue will be addressed in a future update. When you get a time-out error after trying to send an email, does that email appear in your Sent folder?

    Becky K.
    Cox Support Forums Moderator