Problems with webmail login page.

Dear Cox,

This message is for the website support team. I could not find their contact info on those fancy contact us pages for residential customers, so I hope someone passes this along to them.

For more than one year now, I've had significant issues with your web mail login page. Allow me to explain.

1. It doesn't work.

2. When it does work,  two out of three times it will load to the inbox page. 2 out 3. The other  1 out of 3, it does NOT load. The page cycles for 2 to 3 minutes, and then it times out.

3. When it does manage to load itself to the inbox page, it takes on average, 2 to 3 minutes. That's not an exaggeration. That is how long it takes.

4. My cox email is sync'd with my outlook email client on my desktop. That part works fine. However, cox keeps sending my boss's emails to my online web spam folder. Every single time. I have marked his emails as "Not Spam" a minimum of 30 times, maybe 40, but Cox keeps sending his emails to my spam folder. The only reason I have to go through your webmail is to retrieve his messages. But, as I said, that only works 2 out of 3 times. I have put together a visual illustration to show what happens after your webmail page fails to cycle after 2-3 minutes. I think it's pretty good. See below.

I've been a webmaster for 17 years. I've never seen a webmail system that performs, or fails to perform, worse than this one.

Proposed resolutions.

1. Stop sending my boss's emails to my webmail's spam folder.

2. Reprogram the login page so that it works like it has Cable Internet, instead of like it has 1997 56kb dial up speeds.

Thank you for your time.

Kind Regards,

JLM1970

What cox webmail looks like 1 out 3 times.

Parents
No Data
Reply
  • Hi JLM1970. We can certainly assist you with the issues you are having. Please email cox.help@cox.com with your email address that is having the issues along with this link and we will need to escalate the issue regarding your boss's emails being marked as spam. As for the issue with the website, it looks like you are using the wrong site to log into. Try using idm.east.cox.net/.../myemail. Before doing this, please delete all browsing history and don't use any saved bookmarks or favorites that you previously used for webmail. Thanks, Lisa - Cox Support Forums Moderator
Children
No Data